<!DOCTYPE html>
<html lang="en-US" class="mobile">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="https://www.smudailycampus.com/xmlrpc.php">

<meta property="og:title" content="Snowstorm Make-Up Day Plan Does Not Receive Majority Student Approval"><meta property="og:description" content="With the announcement that SMU would use Good Friday and the first reading day to make up class missed due to the February snowstorm, many students told The Daily Campus they did not support the decision."><meta property="og:image" content="https://www.smudailycampus.com/wp-content/uploads/2021/03/Thye_20210215_033-2-DC.jpg"><meta name="twitter:card" content="summary_large_image"><title>Snowstorm Make-Up Day Plan Does Not Receive Majority Student Approval &#8211; SMU Daily Campus</title>
<link rel='dns-prefetch' href='//cdn.broadstreetads.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="SMU Daily Campus &raquo; Feed" href="https://www.smudailycampus.com/feed" />
<link rel="alternate" type="application/rss+xml" title="SMU Daily Campus &raquo; Comments Feed" href="https://www.smudailycampus.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="SMU Daily Campus &raquo; Snowstorm Make-Up Day Plan Does Not Receive Majority Student Approval Comments Feed" href="https://www.smudailycampus.com/news/snowstorm-make-up-day-plan-does-not-receive-majority-student-approval/feed" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.smudailycampus.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.4"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel="stylesheet" href="https://www.smudailycampus.com/wp-content/cache/minify/82b25.css" media="all" />






<link rel='stylesheet' id='times-fonts-css'  href='https://fonts.googleapis.com/css?family=PT+Serif%3A400%2C700%2C700italic%7CDomine%3A400%2C700%7CWork+Sans%3A300%2C400%2C500%2C600%2C700%2C900&#038;subset=latin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext%2Cgreek%2Cgreek-ext%2Cvietnamese&#038;ver=5.4.4' type='text/css' media='all' />
<link rel="stylesheet" href="https://www.smudailycampus.com/wp-content/cache/minify/576ad.css" media="all" />

<script type='text/javascript' data-cfasync='false' src='//cdn.broadstreetads.com/init-2.min.js?ver=5.4.4'></script>
<script src="https://www.smudailycampus.com/wp-content/cache/minify/df983.js"></script>


<link rel='https://api.w.org/' href='https://www.smudailycampus.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.smudailycampus.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.smudailycampus.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.4.4" />
<link rel="canonical" href="https://www.smudailycampus.com/news/snowstorm-make-up-day-plan-does-not-receive-majority-student-approval" />
<link rel='shortlink' href='https://www.smudailycampus.com/?p=1058500' />
<link rel="alternate" type="application/json+oembed" href="https://www.smudailycampus.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.smudailycampus.com%2Fnews%2Fsnowstorm-make-up-day-plan-does-not-receive-majority-student-approval" />
<link rel="alternate" type="text/xml+oembed" href="https://www.smudailycampus.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.smudailycampus.com%2Fnews%2Fsnowstorm-make-up-day-plan-does-not-receive-majority-student-approval&#038;format=xml" />

		<!-- GA Google Analytics @ https://m0n.co/ga -->
		<script>
			(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
			ga('create', 'UA-25702568-1', 'auto');
			ga('send', 'pageview');
		</script>

	<meta name="twitter:partner" content="tfwp"><link rel="icon" href="https://www.smudailycampus.com/wp-content/uploads/2020/05/cropped-Favicon512x512-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.smudailycampus.com/wp-content/uploads/2020/05/cropped-Favicon512x512-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.smudailycampus.com/wp-content/uploads/2020/05/cropped-Favicon512x512-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.smudailycampus.com/wp-content/uploads/2020/05/cropped-Favicon512x512-1-270x270.png" />

<meta name="twitter:card" content="summary"><meta name="twitter:title" content="Snowstorm Make-Up Day Plan Does Not Receive Majority Student Approval"><meta name="twitter:description" content="With the announcement that SMU would use Good Friday and the first reading day to make up class missed due to the February snowstorm, many students told The Daily Campus they did not support the decision."><meta name="twitter:image" content="https://www.smudailycampus.com/wp-content/uploads/2021/03/Thye_20210215_033-2-DC.jpg">
		<style type="text/css" id="wp-custom-css">
			.label ul.post-categories li{display:inline-block!important;margin-right:2px}.post.mass .introduction .label{background:none!important;padding:0}.post.mass .introduction .label li{background:#aaa;padding:0 12px;border-radius:3px}		</style>
		<style id="timesShade3ColorCustom" type="text/css" media="screen">#commentform,#comments,#comments .comment-content,#comments .tvote-wrap,#comments #respond~p,#site-navigation .rich-dropdown .child-cats,#sec-navigation .menu li,#site-navigation.custom-menu .std-dropdown>ul>li,.archive-pagination ul.page-numbers li a.page-numbers:hover,.bass p,.bass ul,.bass ol,.introduction .times-breadcrumbs>span.item-current:hover,.introduction.archive-header.author .meta.author-bio .bio,.introduction.archive-header.author .meta.author-bio .bio:hover,.post-author-bio p,.post.expt .excerpt,.post.mass .content,.post.mass .content form.post-password-form>p:first-child,.post.mass .content form>p input[type=button], .post.mass .content form>p input[type=date], .post.mass .content form>p input[type=datetime-local], .post.mass .content form>p input[type=email], .post.mass .content form>p input[type=file], .post.mass .content form>p input[type=month], .post.mass .content form>p input[type=number], .post.mass .content form>p input[type=password], .post.mass .content form>p input[type=reset], .post.mass .content form>p input[type=search], .post.mass .content form>p input[type=submit], .post.mass .content form>p input[type=tel], .post.mass .content form>p input[type=text], .post.mass .content form>p input[type=time], .post.mass .content form>p input[type=url], .post.mass .content form>p input[type=week],.post.mass .content form>p textarea,.post.mass .content form>p select,.post.mass .content ol:not([class]) u,.post.mass .content ul:not([class]) u,.post.mass .content>p:not(.long)>u,.post.mass .content .wp-block-pullquote cite,.post.mass .content .wp-block-quote cite,.post.mass .content .wp-block-file a:not([download]):first-of-type:before,.post.mass .content .wp-block-times-button a.style-minimal:before,.query-fade-wrap .info,.search-form .search-submit,.site-footer .site-branding,.site-footer .widget,.site-footer .widget-area .widget_nav_menu a:not(:hover),.site-footer.mini-layout .social-networks a:not(:hover),.stats .stat .text,.times-mini-stats .stat .count,.widget-area.article-sidebar .tags,body.times-customizer-focus-sidebar .widget-area.article-sidebar:not(:hover) .bass a,body.times-customizer-focus-sidebar .widget-area.article-sidebar:not(:hover) .post-author-bio a,body.error404 .e404-header .go-back,#times-legal-notice .notice-desc-box{color:#070707;}#site-navigation .rich-dropdown .child-cats li.active a,.load-more span,body.times-customizer-focus-sidebar .widget-area.article-sidebar:not(:hover) .times-post-share-buttons a:nth-of-type(odd),.site-footer .widget.categories a span.count,#comments .times-comments-control .sorting div.active,#comments .times-comments-control .comments-pagination div{background:#070707;}</style>
<script type="text/javascript">function timesWO(o,n,e,t){var r=screen.width/2-e/2,i=screen.height/2-t/2;return window.open(o,n,"toolbar=no, location=no, directories=no, status=no, menubar=no, scrollbars=no, resizable=no, copyhistory=no, width="+e+", height="+t+", top="+i+", left="+r)}var timesStickySidebar=true;var timesSpecialLayout=true;var timesHeroParallax=true;var timesElevateClick=true;var timesLoadFade=true;var timesLoadFadeIn=true;var isSafariFade=/^((?!chrome|android).)*safari/i.test(navigator.userAgent);var timesScrollTo=false;var timesTransparentLabels=true;var timesAutoHyphenate="disabled";var timesHyphenateBranding=false;var timesExptTweak=true;var timesFeaturedParagraph=true;var timesAutoDropCap=true;var timesHeaderLayout='compact-mobile';var timesMenuLayout='basic';var timesMobileMenuLayout='compact-mobile';var timesIsCustomizer=false;var timesIsTicker=false;var timesHomepagePostIDs=[];var timesIgnoreMailtoLinks=false;var timesHomepageUnique=true;var timesHomepageUsedPostsJSON=[];var timesCalculateSidebar=0;var timesSingularPostID=1058500;var timesSingularBaseURL='/news/snowstorm-make-up-day-plan-does-not-receive-majority-student-approval';var timesPostDisableFeaturedParagraph=false;var timesPostDisableAutoDropCap=false;var timesPostCommentPageNumber=1;var timesPostCommentDefaultSorting='oldest';</script></head>

<body class="post-template-default single single-post postid-1058500 single-format-standard standard-article-layout times-customizer-focus-sidebar">
<script type="text/javascript">(function($){"use strict";function fadeInPage(){function d(){setTimeout(function(){$("body").addClass("loaded")},8e3)}d(),1==isSafariFade&&$("body").addClass("zero loaded"),1==isSafariFade&&0==timesLoadFade&&$("body").ready(function(){$("body").addClass("zero loaded")}),1==timesLoadFadeIn&&$(window).bind("load",function(){$("body").addClass("loaded")}),$(window).bind("beforeunload",function(){1!=isSafariFade&&0!=timesLoadFade&&(timesIgnoreMailtoLinks?timesIgnoreMailtoLinks=!1:($("body").removeClass("zero loaded"),setTimeout(function(){$("body").addClass("loaded")},6e3))),d()})}$("html").addClass("js"),"opacity"in document.documentElement.style&&$("html").addClass("js-opacity"),"onmouseover"in document.documentElement&&$("html").addClass("hoverable"),fadeInPage();})(jQuery);if ( isSafariFade || timesLoadFade && !timesLoadFadeIn || !timesLoadFadeIn ) document.body.classList.add("zero", "loaded");</script><a class="skip-link screen-reader-text before-header-link" href="#content">Skip to content</a>

<header id="mobile-nav" role="banner" class="compact-layout">
	<div class="site-id-bar">
		<div class="menu-btn"><span class="menu-icon">Menu</span></div>
		<div class="site-id">
					<a href="https://www.smudailycampus.com/" rel="home"><h1 class="site-name">SMU Daily Campus</h1></a>
				</div>
		<form class="custom-search-form" role="search" method="get" action="https://www.smudailycampus.com/" autocomplete="off">
			<div class="search-btn"><span class="screen-reader-text">Search</span><input type="submit" value="a"><img src="https://www.smudailycampus.com/wp-content/themes/times/img/magni.svg" class="svg-inject"></div>
			<div class="search-field-area">
				<input type="search" class="search-field" placeholder="Type your search query" name="s" value="">
				<div class="close-search"><span class="screen-reader-text">Close search</span><img src="https://www.smudailycampus.com/wp-content/themes/times/img/close11.svg" class="svg-inject"></div>
			</div>
		</form>
	</div>
	<div class="menu-section">
		<div class="close-menu-btn"><span class="close">Close</span></div>
		<nav class="menu-container">
			<div class="wrap">
				<div class="menu-main-navigation-container"><ul id="primary-menu" class="menu"><li id="menu-item-1045612" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-1045612"><a href="https://www.smudailycampus.com/category/news">News</a>
<ul class="sub-menu">
	<li id="menu-item-1050668" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1050668"><a href="https://www.smudailycampus.com/category/politics">Politics</a></li>
	<li id="menu-item-1053738" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1053738"><a href="https://www.smudailycampus.com/category/news/crime">Crime</a></li>
	<li id="menu-item-1053737" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1053737"><a href="https://www.smudailycampus.com/category/news/campuslife">Campus Life</a></li>
</ul>
</li>
<li id="menu-item-1045613" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1045613"><a href="https://www.smudailycampus.com/category/sports">Sports</a>
<ul class="sub-menu">
	<li id="menu-item-1045663" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1045663"><a href="https://www.smudailycampus.com/category/sports/basketball">Basketball</a></li>
	<li id="menu-item-1045664" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1045664"><a href="https://www.smudailycampus.com/category/sports/football">Football</a></li>
	<li id="menu-item-1045666" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1045666"><a href="https://www.smudailycampus.com/category/sports/soccer">Soccer</a>
	<ul class="sub-menu">
		<li id="menu-item-1053794" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1053794"><a href="https://www.smudailycampus.com/category/sports/soccer/mens">Men&#8217;s</a></li>
		<li id="menu-item-1053795" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1053795"><a href="https://www.smudailycampus.com/category/sports/soccer/womens">Women&#8217;s</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-1045614" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1045614"><a href="https://www.smudailycampus.com/category/opinion">Opinion</a></li>
<li id="menu-item-1045615" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1045615"><a href="https://www.smudailycampus.com/category/ae">Arts &#038; Culture</a>
<ul class="sub-menu">
	<li id="menu-item-1050662" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1050662"><a href="https://www.smudailycampus.com/category/ae/meadows">Meadows</a></li>
	<li id="menu-item-1053736" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1053736"><a href="https://www.smudailycampus.com/category/ae/entertainment">Entertainment</a></li>
	<li id="menu-item-1053735" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1053735"><a href="https://www.smudailycampus.com/category/ae/culture">Culture</a></li>
	<li id="menu-item-1053734" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1053734"><a href="https://www.smudailycampus.com/category/ae/creative">Creative</a></li>
</ul>
</li>
<li id="menu-item-1054669" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1054669"><a href="https://www.smudailycampus.com/category/specialproject">Special Project</a>
<ul class="sub-menu">
	<li id="menu-item-1055747" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1055747"><a href="https://www.smudailycampus.com/category/specialproject/classofcovid">Class of COVID</a></li>
	<li id="menu-item-1054671" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1054671"><a href="https://www.smudailycampus.com/category/news/sex-trafficking-north-texas">Sex Trafficking in North Texas</a></li>
	<li id="menu-item-1054670" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1054670"><a href="https://www.smudailycampus.com/category/news/gentrification">Gentrification Across Dallas</a></li>
</ul>
</li>
<li id="menu-item-1057018" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1057018"><a href="https://www.smudailycampus.com/category/espanol-%e4%b8%ad%e6%96%87">Español/中文</a>
<ul class="sub-menu">
	<li id="menu-item-1057019" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1057019"><a href="https://www.smudailycampus.com/category/espanol-%e4%b8%ad%e6%96%87/espanol">Español</a></li>
	<li id="menu-item-1057017" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1057017"><a href="https://www.smudailycampus.com/category/espanol-%e4%b8%ad%e6%96%87/%e4%b8%ad%e6%96%87">中文</a></li>
</ul>
</li>
<li id="menu-item-1050608" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1050608"><a target="_blank" rel="noopener noreferrer" href="http://smulook.com/">SMU Look</a></li>
<li id="menu-item-1045616" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1045616"><a href="https://www.smudailycampus.com/category/smu-tv">SMU-TV</a>
<ul class="sub-menu">
	<li id="menu-item-1046403" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1046403"><a href="https://www.smudailycampus.com/category/smu-tv/the-daily-update">The Daily Update</a></li>
	<li id="menu-item-1046401" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1046401"><a href="https://www.smudailycampus.com/category/smu-tv/press-pass">Press Pass</a></li>
	<li id="menu-item-1049261" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1049261"><a href="https://www.smudailycampus.com/category/smu-tv/real-talk">Real Talk</a></li>
</ul>
</li>
<li id="menu-item-1048384" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1048384"><a href="https://www.smudailycampus.com/weather">Weather</a></li>
</ul></div><h3>More links</h3><div class="menu-top-menu-container"><ul id="secondary-menu" class="menu"><li id="menu-item-1053753" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-1053753"><a href="https://www.smudailycampus.com/staff/contact-our-staff">Contact Our Editors</a></li>
<li id="menu-item-1052804" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1052804"><a href="https://smu.nbsstore.net/journalism">Advertising</a></li>
<li id="menu-item-1052605" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1052605"><a href="https://www.smudailycampus.com/classifieds">Classifieds</a></li>
<li id="menu-item-1052640" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1052640"><a href="https://www.smudailycampus.com/category/sponsoredcontent/college101">College 101</a></li>
</ul></div><div class="social-media-container">
	<h3>Social Media</h3>

	<ul class="social-media-list"><li class="facebook"><a href="https://www.facebook.com/thedailycampus" target="_blank">Facebook</a></li><li class="instagram"><a href="https://www.instagram.com/smudailycampus/" target="_blank">Instagram</a></li><li class="twitter"><a href="https://twitter.com/thedailycampus" target="_blank">Twitter</a></li></ul>			</div>
		</nav>
	</div>
	<!-- .search-results -->
</header>
	<div class="row" id="content">

		<div class="col lt10">
			<article class="post mass single standard-layout post-1058500 type-post status-publish format-standard hentry category-campuslife category-featured category-news category-student-life tag-smu tag-snowstorm tag-students" id="post-1058500">

				<div class="introduction">
	<div class="category-labels"><div class="label full-text label-cat-id-14125"><span class="label-category-name">Campus Life</span><a class="label-category-link" href="https://www.smudailycampus.com/category/news/campuslife" rel="category"></a></div></div>	<h1 class="title">Snowstorm Make-Up Day Plan Does Not Receive Majority Student Approval</h1>
	<p class="meta"><span class="published-ago"><time datetime="2021-03-08T11:46:18-06:00">2021/03/08 at 11:46 AM</time><span class="hyphen">&nbsp;-&nbsp;</span></span><a href="https://www.smudailycampus.com/author/julia-fox" rel="author" class="author">Julia Fox</a><span class="short-ago"><span class="hyphen">&nbsp;-&nbsp;</span><time datetime="2021-03-08T11:46:18-06:00">6h ago</time> </span></p></div>

				<hr>

				<figure class="featured-image"><img class="attachment-single-thumb size-single-thumb wp-post-image" alt width="800" height="533" srcset="https://www.smudailycampus.com/wp-content/uploads/2021/03/Thye_20210215_033-2-DC-360x240.jpg 360w, https://www.smudailycampus.com/wp-content/uploads/2021/03/Thye_20210215_033-2-DC-700x466.jpg 700w, https://www.smudailycampus.com/wp-content/uploads/2021/03/Thye_20210215_033-2-DC-720x480.jpg 720w, https://www.smudailycampus.com/wp-content/uploads/2021/03/Thye_20210215_033-2-DC-780x520.jpg 780w, https://www.smudailycampus.com/wp-content/uploads/2021/03/Thye_20210215_033-2-DC.jpg 1120w, https://www.smudailycampus.com/wp-content/uploads/2021/03/Thye_20210215_033-2-DC.jpg 1400w, https://www.smudailycampus.com/wp-content/uploads/2021/03/Thye_20210215_033-2-DC.jpg 1560w, https://www.smudailycampus.com/wp-content/uploads/2021/03/Thye_20210215_033-2-DC.jpg 2240w" sizes="(min-width:1200px) 780px, (min-width:1200px) and (min-aspect-ratio:2) 1560px, (min-width:600px) 700px, (min-width:600px) and (min-aspect-ratio:2) 1400px, (min-width:360px) 360px, (min-width:360px) and (min-aspect-ratio:2) 720px, 100vw"><figcaption>Photo credit: Ash Thye</figcaption></figure>
				<div class="content bass">
					<p>On March 2, Elizabeth Loboa, Provost and Vice President for Academic Affairs, sent an email to students, faculty and staff announcing Good Friday and the first reading day would be used to make up class that was missed due to the snowstorm.</p>
<p>Many students were upset. </p>
<p>With the absence of Spring Break from this semester, Good Friday was meant to be the only day students had off &#8212; and now that break is gone, too. </p>
<p>Reading days are meant to help students take some time to prepare for their finals. </p>
<p>In a poll conducted by <i>The Daily Campus,</i> 59% of participants voted they do not approve of the decision to use Good Friday and the first reading day to make up lost class time.</p>
<p>&#8220;It&#8217;s frankly inhumane. We don&#8217;t have a single day off this semester,&#8221; said Reeth Magoo, SMU sophomore. &#8220;Meanwhile, other colleges are scheduling mental health days off.&#8221;</p>
<p>Many schools &#8212; like TCU, Notre Dame and Duke &#8212; that do not have spring breaks this semester, are providing &#8220;Mental Health Days&#8221; to their students and staff. SMU is not.</p>
<p>&#8220;We already don&#8217;t have any breaks this semester,&#8221; said Holly Gray, SMU sophomore. &#8220;Also, reading days are very needed to prepare for finals.&#8221; Many students messaged the Daily Campus on Instagram saying that they feel they are being rushed through finals.</p>
<p>&#8220;I&#8217;m pretty upset about SMU&#8217;s decision to take away Good Friday and the first reading day,&#8221; said Maggie Higgins, SMU Junior. &#8220;I think a lot of people were already feeling pretty overwhelmed this semester knowing we had no spring break, and this on top of it all just makes it even more stressful.&#8221;</p>
									</div>

				<aside class="mobile-post-info mobile-sidebar">
					<span class="meta-prep meta-prep-author">Posted on</span> <a href="https://www.smudailycampus.com/news/snowstorm-make-up-day-plan-does-not-receive-majority-student-approval" title="11:46 am" rel="bookmark"><span class="entry-date">March 8th, 2021</span></a> <span class="meta-sep">by</span> <a href="https://www.smudailycampus.com/author/julia-fox" title="Posts by Julia Fox" class="author url fn" rel="author">Julia Fox</a>
					<section class="times-post-share-buttons bass-share-buttons"><a class="facebook" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.smudailycampus.com%2Fnews%2Fsnowstorm-make-up-day-plan-does-not-receive-majority-student-approval" onclick="event.preventDefault(); timesWO('https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.smudailycampus.com%2Fnews%2Fsnowstorm-make-up-day-plan-does-not-receive-majority-student-approval', 'Share this post on Facebook', '540', '460')">Share</a><a class="twitter" href="https://twitter.com/home?status=https%3A%2F%2Fwww.smudailycampus.com%2Fnews%2Fsnowstorm-make-up-day-plan-does-not-receive-majority-student-approval" onclick="event.preventDefault(); timesWO('https://twitter.com/home?status=https%3A%2F%2Fwww.smudailycampus.com%2Fnews%2Fsnowstorm-make-up-day-plan-does-not-receive-majority-student-approval', 'Share this post on Twitter', '540', '500')">Tweet</a><a class="gplus" href="https://plus.google.com/share?url=https%3A%2F%2Fwww.smudailycampus.com%2Fnews%2Fsnowstorm-make-up-day-plan-does-not-receive-majority-student-approval" onclick="event.preventDefault(); timesWO('https://plus.google.com/share?url=https%3A%2F%2Fwww.smudailycampus.com%2Fnews%2Fsnowstorm-make-up-day-plan-does-not-receive-majority-student-approval', 'Share this post on Google+', '512', '500')"><span class="screen-reader-text">Share on Google+</span></a><a class="pinterest" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.smudailycampus.com%2Fnews%2Fsnowstorm-make-up-day-plan-does-not-receive-majority-student-approval&amp;media=https://www.smudailycampus.com/wp-content/uploads/2021/03/Thye_20210215_033-2-DC.jpg&amp;description=WordPress" onclick="event.preventDefault(); timesWO('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.smudailycampus.com%2Fnews%2Fsnowstorm-make-up-day-plan-does-not-receive-majority-student-approval&amp;media=https://www.smudailycampus.com/wp-content/uploads/2021/03/Thye_20210215_033-2-DC.jpg&amp;description=WordPress', 'Share this post on Pinterest', '540', '500')"><span class="screen-reader-text">Pin on Pinterest</span></a><a class="whatsapp" href="whatsapp://send?text=https%3A%2F%2Fwww.smudailycampus.com%2Fnews%2Fsnowstorm-make-up-day-plan-does-not-receive-majority-student-approval"><span class="screen-reader-text">Send with WhatsApp</span></a></section>
									</aside>

				<section class="inaction clear"><div class="btn recommend-btn tvote-wrap"><a href="https://www.smudailycampus.com/wp-admin/admin-ajax.php?action=times_process_times_vote&nonce=8909635ff1&post_id=1058500&disabled=true&is_comment=false" class="tvote-button tvote-button-1058500" data-nonce="8909635ff1" data-post-id="1058500" data-iscomment="false"></a><img src="https://www.smudailycampus.com/wp-content/themes/times/img/big-bookmark.svg" class="svg-inject"></div><div class="btn share-btn"><img src="https://www.smudailycampus.com/wp-content/themes/times/img/share-big.svg" alt="comments icon" class="svg-inject share-icon"><span>Share</span><div class="tooltip bass-share-buttons"><a class="facebook" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.smudailycampus.com%2Fnews%2Fsnowstorm-make-up-day-plan-does-not-receive-majority-student-approval" onclick="event.preventDefault(); timesWO('https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.smudailycampus.com%2Fnews%2Fsnowstorm-make-up-day-plan-does-not-receive-majority-student-approval', 'Share this post on Facebook', '540', '460')">Share</a><a class="twitter" href="https://twitter.com/home?status=https%3A%2F%2Fwww.smudailycampus.com%2Fnews%2Fsnowstorm-make-up-day-plan-does-not-receive-majority-student-approval" onclick="event.preventDefault(); timesWO('https://twitter.com/home?status=https%3A%2F%2Fwww.smudailycampus.com%2Fnews%2Fsnowstorm-make-up-day-plan-does-not-receive-majority-student-approval', 'Share this post on Twitter', '540', '500')">Tweet</a><a class="gplus" href="https://plus.google.com/share?url=https%3A%2F%2Fwww.smudailycampus.com%2Fnews%2Fsnowstorm-make-up-day-plan-does-not-receive-majority-student-approval" onclick="event.preventDefault(); timesWO('https://plus.google.com/share?url=https%3A%2F%2Fwww.smudailycampus.com%2Fnews%2Fsnowstorm-make-up-day-plan-does-not-receive-majority-student-approval', 'Share this post on Google+', '512', '500')">Share</a><a class="pinterest" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.smudailycampus.com%2Fnews%2Fsnowstorm-make-up-day-plan-does-not-receive-majority-student-approval&amp;media=https://www.smudailycampus.com/wp-content/uploads/2021/03/Thye_20210215_033-2-DC.jpg&amp;description=WordPress" onclick="event.preventDefault(); timesWO('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.smudailycampus.com%2Fnews%2Fsnowstorm-make-up-day-plan-does-not-receive-majority-student-approval&amp;media=https://www.smudailycampus.com/wp-content/uploads/2021/03/Thye_20210215_033-2-DC.jpg&amp;description=WordPress', 'Share this post on Pinterest', '540', '500')">Pin it</a><button class="copy-link" data-times-copied-string="Copied!" data-clipboard-text="https://www.smudailycampus.com/news/snowstorm-make-up-day-plan-does-not-receive-majority-student-approval">Copy link</button><a class="email-link" href="mailto:friend@example.com?subject=Link&body=Check%20out%20this%20link%20I%E2%80%99ve%20found%3A%0A%0Ahttps%3A%2F%2Fwww.smudailycampus.com%2Fnews%2Fsnowstorm-make-up-day-plan-does-not-receive-majority-student-approval">Email</a></div></div></section>
			</article>
		</div>

		<div class="col lt5">

			<div class="stats">
									<div class="stat post-views">
						<span class="count">0</span> <span class="text">views</span>					</div>
				
								<div class="bookmark-post tvote-wrap" title="Bookmark">
					<a href="https://www.smudailycampus.com/wp-admin/admin-ajax.php?action=times_process_times_vote&nonce=8909635ff1&post_id=1058500&disabled=true&is_comment=false" class="tvote-button tvote-button-1058500" data-nonce="8909635ff1" data-post-id="1058500" data-iscomment="false"></a>					<img src="https://www.smudailycampus.com/wp-content/themes/times/img/bookmark-single.svg" alt="bookmark icon" class="svg-inject">
				</div>
				
			</div>

			<aside class="widget-area article-sidebar">

								<section class="widget post-info">
					<h2 class="widget-title bd2">Article info</h2>

					<span class="meta-prep meta-prep-author">Posted on</span> <a href="https://www.smudailycampus.com/news/snowstorm-make-up-day-plan-does-not-receive-majority-student-approval" title="11:46 am" rel="bookmark"><span class="entry-date">March 8th, 2021</span></a> <span class="meta-sep">by</span> <a href="https://www.smudailycampus.com/author/julia-fox" title="Posts by Julia Fox" class="author url fn" rel="author">Julia Fox</a>
										<div class="tags">
						<span class="hash">#</span><a href="https://www.smudailycampus.com/tag/smu" rel="tag">SMU</a><span class="comma">, </span><a href="https://www.smudailycampus.com/tag/snowstorm" rel="tag">Snowstorm</a><span class="comma">, </span><a href="https://www.smudailycampus.com/tag/students" rel="tag">students</a>					</div>
									</section>
				
						<section class="widget times-related-posts">
			<h2 class="widget-title bd2">Related posts</h2><article class="post horiz-mini expt post-id-1058471 cover">
			<div class="thumbnail">
			<a href="https://www.smudailycampus.com/news/smu-continues-to-require-masks-and-social-distancing-on-campus" rel="bookmark"><img width="54" height="54" src="https://www.smudailycampus.com/wp-content/uploads/2021/03/smumaskmandate-54x54.jpg" class="attachment-times-horiz-mini size-times-horiz-mini wp-post-image" alt="" srcset="https://www.smudailycampus.com/wp-content/uploads/2021/03/smumaskmandate-54x54.jpg 54w, https://www.smudailycampus.com/wp-content/uploads/2021/03/smumaskmandate-72x72.jpg 72w, https://www.smudailycampus.com/wp-content/uploads/2021/03/smumaskmandate-144x144.jpg 144w, https://www.smudailycampus.com/wp-content/uploads/2021/03/smumaskmandate-108x108.jpg 108w, https://www.smudailycampus.com/wp-content/uploads/2021/03/smumaskmandate-58x58.jpg 58w, https://www.smudailycampus.com/wp-content/uploads/2021/03/smumaskmandate-116x116.jpg 116w" sizes="100vw" /></a>
			<div class="tvote-wrap small"><span class="button"><a href="https://www.smudailycampus.com/wp-admin/admin-ajax.php?action=times_process_times_vote&nonce=8909635ff1&post_id=1058471&disabled=true&is_comment=false" class="tvote-button tvote-button-1058471" data-nonce="8909635ff1" data-post-id="1058471" data-iscomment="false"></a><img class="bookmark-small svg-inject" src="https://www.smudailycampus.com/wp-content/themes/times/img/bookmark-small.svg"></span><span class="context tooltip center-top"><span class="add">Bookmark?</span><span class="remove">Remove?</span></span></div>		</div>
		<div class="caption">
		<h1 class="title"><a href="https://www.smudailycampus.com/news/smu-continues-to-require-masks-and-social-distancing-on-campus" rel="bookmark">SMU Continues to Require Masks and Social Distancing On-Campus</a></h1>
		<p class="meta"><time datetime="2021-03-03T13:57:15-06:00">2021/03/03 at 1:57 PM</time><span class="bookmarks"><span class="hyphen">&nbsp;-&nbsp;</span>29 bookmarks</span></p>	</div>
</article><article class="post horiz-mini expt post-id-1058417 cover">
			<div class="thumbnail">
			<a href="https://www.smudailycampus.com/sports/i-cant-comprehend-it-after-week-of-once-in-a-generation-events-smus-once-promising-sprint-to-march-is-now-in-peril" rel="bookmark"><img width="54" height="54" src="https://www.smudailycampus.com/wp-content/uploads/2021/02/PH2Ytyj4-54x54.jpeg" class="attachment-times-horiz-mini size-times-horiz-mini wp-post-image" alt="" srcset="https://www.smudailycampus.com/wp-content/uploads/2021/02/PH2Ytyj4-54x54.jpeg 54w, https://www.smudailycampus.com/wp-content/uploads/2021/02/PH2Ytyj4-72x72.jpeg 72w, https://www.smudailycampus.com/wp-content/uploads/2021/02/PH2Ytyj4-144x144.jpeg 144w, https://www.smudailycampus.com/wp-content/uploads/2021/02/PH2Ytyj4-108x108.jpeg 108w, https://www.smudailycampus.com/wp-content/uploads/2021/02/PH2Ytyj4-58x58.jpeg 58w, https://www.smudailycampus.com/wp-content/uploads/2021/02/PH2Ytyj4-116x116.jpeg 116w" sizes="100vw" /></a>
			<div class="tvote-wrap small"><span class="button"><a href="https://www.smudailycampus.com/wp-admin/admin-ajax.php?action=times_process_times_vote&nonce=8909635ff1&post_id=1058417&disabled=true&is_comment=false" class="tvote-button tvote-button-1058417" data-nonce="8909635ff1" data-post-id="1058417" data-iscomment="false"></a><img class="bookmark-small svg-inject" src="https://www.smudailycampus.com/wp-content/themes/times/img/bookmark-small.svg"></span><span class="context tooltip center-top"><span class="add">Bookmark?</span><span class="remove">Remove?</span></span></div>		</div>
		<div class="caption">
		<h1 class="title"><a href="https://www.smudailycampus.com/sports/i-cant-comprehend-it-after-week-of-once-in-a-generation-events-smus-once-promising-sprint-to-march-is-now-in-peril" rel="bookmark">&#8216;I can&#8217;t comprehend it&#8217;: After week of once-in-a-generation events, SMU&#8217;s once promising sprint to March is now in peril</a></h1>
		<p class="meta"><time datetime="2021-02-23T04:38:01-06:00">2021/02/23 at 4:38 AM</time><span class="bookmarks"><span class="hyphen">&nbsp;-&nbsp;</span>58 bookmarks</span></p>	</div>
</article><article class="post horiz-mini expt post-id-1058413 cover">
			<div class="thumbnail">
			<a href="https://www.smudailycampus.com/news/boil-notice-lifted-campus-recovery-continues" rel="bookmark"><img width="54" height="54" src="https://www.smudailycampus.com/wp-content/uploads/2021/02/Thye_20210215_033-2-DC-54x54.jpg" class="attachment-times-horiz-mini size-times-horiz-mini wp-post-image" alt="" srcset="https://www.smudailycampus.com/wp-content/uploads/2021/02/Thye_20210215_033-2-DC-54x54.jpg 54w, https://www.smudailycampus.com/wp-content/uploads/2021/02/Thye_20210215_033-2-DC-72x72.jpg 72w, https://www.smudailycampus.com/wp-content/uploads/2021/02/Thye_20210215_033-2-DC-144x144.jpg 144w, https://www.smudailycampus.com/wp-content/uploads/2021/02/Thye_20210215_033-2-DC-108x108.jpg 108w, https://www.smudailycampus.com/wp-content/uploads/2021/02/Thye_20210215_033-2-DC-58x58.jpg 58w, https://www.smudailycampus.com/wp-content/uploads/2021/02/Thye_20210215_033-2-DC-116x116.jpg 116w" sizes="100vw" /></a>
			<div class="tvote-wrap small"><span class="button"><a href="https://www.smudailycampus.com/wp-admin/admin-ajax.php?action=times_process_times_vote&nonce=8909635ff1&post_id=1058413&disabled=true&is_comment=false" class="tvote-button tvote-button-1058413" data-nonce="8909635ff1" data-post-id="1058413" data-iscomment="false"></a><img class="bookmark-small svg-inject" src="https://www.smudailycampus.com/wp-content/themes/times/img/bookmark-small.svg"></span><span class="context tooltip center-top"><span class="add">Bookmark?</span><span class="remove">Remove?</span></span></div>		</div>
		<div class="caption">
		<h1 class="title"><a href="https://www.smudailycampus.com/news/boil-notice-lifted-campus-recovery-continues" rel="bookmark">Boil Notice Lifted, Campus Recovery Continues</a></h1>
		<p class="meta"><time datetime="2021-02-22T09:44:16-06:00">2021/02/22 at 9:44 AM</time><span class="bookmarks"><span class="hyphen">&nbsp;-&nbsp;</span>58 bookmarks</span></p>	</div>
</article><article class="post horiz-mini expt post-id-1058396 cover">
			<div class="thumbnail">
			<a href="https://www.smudailycampus.com/news/university-park-smu-under-boil-notice-classes-canceled-through-friday" rel="bookmark"><img width="54" height="54" src="https://www.smudailycampus.com/wp-content/uploads/2021/02/Shuttles-Snow-54x54.jpg" class="attachment-times-horiz-mini size-times-horiz-mini wp-post-image" alt="" srcset="https://www.smudailycampus.com/wp-content/uploads/2021/02/Shuttles-Snow-54x54.jpg 54w, https://www.smudailycampus.com/wp-content/uploads/2021/02/Shuttles-Snow-72x72.jpg 72w, https://www.smudailycampus.com/wp-content/uploads/2021/02/Shuttles-Snow-144x144.jpg 144w, https://www.smudailycampus.com/wp-content/uploads/2021/02/Shuttles-Snow-108x108.jpg 108w, https://www.smudailycampus.com/wp-content/uploads/2021/02/Shuttles-Snow-58x58.jpg 58w, https://www.smudailycampus.com/wp-content/uploads/2021/02/Shuttles-Snow-116x116.jpg 116w" sizes="100vw" /></a>
			<div class="tvote-wrap small"><span class="button"><a href="https://www.smudailycampus.com/wp-admin/admin-ajax.php?action=times_process_times_vote&nonce=8909635ff1&post_id=1058396&disabled=true&is_comment=false" class="tvote-button tvote-button-1058396" data-nonce="8909635ff1" data-post-id="1058396" data-iscomment="false"></a><img class="bookmark-small svg-inject" src="https://www.smudailycampus.com/wp-content/themes/times/img/bookmark-small.svg"></span><span class="context tooltip center-top"><span class="add">Bookmark?</span><span class="remove">Remove?</span></span></div>		</div>
		<div class="caption">
		<h1 class="title"><a href="https://www.smudailycampus.com/news/university-park-smu-under-boil-notice-classes-canceled-through-friday" rel="bookmark">University Park, SMU under Boil Notice; Classes Canceled through Friday</a></h1>
		<p class="meta"><time datetime="2021-02-17T14:45:54-06:00">2021/02/17 at 2:45 PM</time><span class="bookmarks"><span class="hyphen">&nbsp;-&nbsp;</span>60 bookmarks</span></p>	</div>
</article></section>
									<section class="widget share-post">
						<h2 class="widget-title bd2">Share this article</h2>
						<section class="times-post-share-buttons bass-share-buttons"><a class="facebook" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.smudailycampus.com%2Fnews%2Fsnowstorm-make-up-day-plan-does-not-receive-majority-student-approval" onclick="event.preventDefault(); timesWO('https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.smudailycampus.com%2Fnews%2Fsnowstorm-make-up-day-plan-does-not-receive-majority-student-approval', 'Share this post on Facebook', '540', '460')">Share</a><a class="twitter" href="https://twitter.com/home?status=https%3A%2F%2Fwww.smudailycampus.com%2Fnews%2Fsnowstorm-make-up-day-plan-does-not-receive-majority-student-approval" onclick="event.preventDefault(); timesWO('https://twitter.com/home?status=https%3A%2F%2Fwww.smudailycampus.com%2Fnews%2Fsnowstorm-make-up-day-plan-does-not-receive-majority-student-approval', 'Share this post on Twitter', '540', '500')">Tweet</a><a class="gplus" href="https://plus.google.com/share?url=https%3A%2F%2Fwww.smudailycampus.com%2Fnews%2Fsnowstorm-make-up-day-plan-does-not-receive-majority-student-approval" onclick="event.preventDefault(); timesWO('https://plus.google.com/share?url=https%3A%2F%2Fwww.smudailycampus.com%2Fnews%2Fsnowstorm-make-up-day-plan-does-not-receive-majority-student-approval', 'Share this post on Google+', '512', '500')"><span class="screen-reader-text">Share on Google+</span></a><a class="pinterest" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.smudailycampus.com%2Fnews%2Fsnowstorm-make-up-day-plan-does-not-receive-majority-student-approval&amp;media=https://www.smudailycampus.com/wp-content/uploads/2021/03/Thye_20210215_033-2-DC.jpg&amp;description=WordPress" onclick="event.preventDefault(); timesWO('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.smudailycampus.com%2Fnews%2Fsnowstorm-make-up-day-plan-does-not-receive-majority-student-approval&amp;media=https://www.smudailycampus.com/wp-content/uploads/2021/03/Thye_20210215_033-2-DC.jpg&amp;description=WordPress', 'Share this post on Pinterest', '540', '500')"><span class="screen-reader-text">Pin on Pinterest</span></a><a class="whatsapp" href="whatsapp://send?text=https%3A%2F%2Fwww.smudailycampus.com%2Fnews%2Fsnowstorm-make-up-day-plan-does-not-receive-majority-student-approval"><span class="screen-reader-text">Send with WhatsApp</span></a></section>					</section>
				
				<div class="user-widgets user-widgets-article">
									</div>

			</aside>
		</div>
	</div>

	<div class="section-darker">
	<div class="row">

		<div class="col st8 lt10">
					</div>

		<aside class="col st7 lt5 widget-area singular-comments-sidebar article-comments-sidebar">

						<section class="recommended-posts widget">
				<h2 class="widget-title bd2">You may find interesting...</h2>
				<article class="post vert tweak expt post-id-1048653 cover">

			<div class="thumbnail">
			<a href="https://www.smudailycampus.com/sm-supporters/underwriters/thanks-to-our-underwriters">
				<img width="360" height="226" src="https://www.smudailycampus.com/wp-content/uploads/2018/09/201808.Underwriters.FeaturedImage-1.jpg" class="attachment-times-horiz size-times-horiz wp-post-image" alt="" srcset="https://www.smudailycampus.com/wp-content/uploads/2018/09/201808.Underwriters.FeaturedImage-1.jpg 1x, https://www.smudailycampus.com/wp-content/uploads/2018/09/201808.Underwriters.FeaturedImage-1.jpg 2x" />			</a>
			<div class="tvote-wrap standard"><span class="button"><i></i><i></i><a href="https://www.smudailycampus.com/wp-admin/admin-ajax.php?action=times_process_times_vote&nonce=8909635ff1&post_id=1048653&disabled=true&is_comment=false" class="tvote-button tvote-button-1048653" data-nonce="8909635ff1" data-post-id="1048653" data-iscomment="false"></a></span><span class="context tooltip"><span class="add">Bookmark?</span><span class="remove">Remove?</span></span></div>		</div>
	
	<div class="caption">
		<h1 class="title"><a href="https://www.smudailycampus.com/sm-supporters/underwriters/thanks-to-our-underwriters" rel="bookmark">Thanks to our underwriters</a></h1>
		<p class="meta"><time datetime="2018-09-04T11:49:29-05:00">2018/09/04 at 11:49 AM</time><span class="hyphen">&nbsp;-&nbsp;</span><a href="https://www.smudailycampus.com/author/candace-barnhill-2" rel="author" class="author">Candace Barnhill</a></p>		<p class="excerpt">Continued publication made possible by our generous sponsors <a href="https://www.smudailycampus.com/sm-supporters/underwriters/thanks-to-our-underwriters" class="more-link" rel="bookmark">More <span>&raquo;</span></a></p>	</div>
</article><article class="post vert tweak expt post-id-1058500 cover">

			<div class="thumbnail">
			<a href="https://www.smudailycampus.com/news/snowstorm-make-up-day-plan-does-not-receive-majority-student-approval">
				<img width="360" height="258" src="https://www.smudailycampus.com/wp-content/uploads/2021/03/Thye_20210215_033-2-DC-360x258.jpg" class="attachment-times-horiz size-times-horiz wp-post-image" alt="" srcset="https://www.smudailycampus.com/wp-content/uploads/2021/03/Thye_20210215_033-2-DC-360x258.jpg 1x, https://www.smudailycampus.com/wp-content/uploads/2021/03/Thye_20210215_033-2-DC-720x516.jpg 2x" />			</a>
			<div class="tvote-wrap standard"><span class="button"><i></i><i></i><a href="https://www.smudailycampus.com/wp-admin/admin-ajax.php?action=times_process_times_vote&nonce=8909635ff1&post_id=1058500&disabled=true&is_comment=false" class="tvote-button tvote-button-1058500" data-nonce="8909635ff1" data-post-id="1058500" data-iscomment="false"></a></span><span class="context tooltip"><span class="add">Bookmark?</span><span class="remove">Remove?</span></span></div>		</div>
	
	<div class="caption">
		<h1 class="title"><a href="https://www.smudailycampus.com/news/snowstorm-make-up-day-plan-does-not-receive-majority-student-approval" rel="bookmark">Snowstorm Make-Up Day Plan Does Not Receive Majority Student Approval</a></h1>
		<p class="meta"><time datetime="2021-03-08T11:46:18-06:00">2021/03/08 at 11:46 AM</time><span class="hyphen">&nbsp;-&nbsp;</span><a href="https://www.smudailycampus.com/author/julia-fox" rel="author" class="author">Julia Fox</a></p>		<p class="excerpt">With the announcement that SMU would use Good Friday and the first reading day to make up class missed due to the February snowstorm, many students told The Daily Campus they did not support the decision. <a href="https://www.smudailycampus.com/news/snowstorm-make-up-day-plan-does-not-receive-majority-student-approval" class="more-link" rel="bookmark">More <span>&raquo;</span></a></p>	</div>
</article>			</section>
			
						<section class="this-cat-posts widget">
				<h2 class="widget-title bd2"><a href="https://www.smudailycampus.com/category/news/campuslife">From this category &raquo;</a></h2>
				<article class="post horiz-mini expt post-id-1058466 cover">
			<div class="thumbnail">
			<a href="https://www.smudailycampus.com/news/diverse-perspectives-create-groundbreaking-journalism-at-the-19th" rel="bookmark"><img width="54" height="54" src="https://www.smudailycampus.com/wp-content/uploads/2021/03/amanda-zamora-54x54.jpeg" class="attachment-times-horiz-mini size-times-horiz-mini wp-post-image" alt="" srcset="https://www.smudailycampus.com/wp-content/uploads/2021/03/amanda-zamora-54x54.jpeg 54w, https://www.smudailycampus.com/wp-content/uploads/2021/03/amanda-zamora-72x72.jpeg 72w, https://www.smudailycampus.com/wp-content/uploads/2021/03/amanda-zamora-144x144.jpeg 144w, https://www.smudailycampus.com/wp-content/uploads/2021/03/amanda-zamora-108x108.jpeg 108w, https://www.smudailycampus.com/wp-content/uploads/2021/03/amanda-zamora-58x58.jpeg 58w, https://www.smudailycampus.com/wp-content/uploads/2021/03/amanda-zamora-116x116.jpeg 116w" sizes="100vw" /></a>
			<div class="tvote-wrap small"><span class="button"><a href="https://www.smudailycampus.com/wp-admin/admin-ajax.php?action=times_process_times_vote&nonce=8909635ff1&post_id=1058466&disabled=true&is_comment=false" class="tvote-button tvote-button-1058466" data-nonce="8909635ff1" data-post-id="1058466" data-iscomment="false"></a><img class="bookmark-small svg-inject" src="https://www.smudailycampus.com/wp-content/themes/times/img/bookmark-small.svg"></span><span class="context tooltip center-top"><span class="add">Bookmark?</span><span class="remove">Remove?</span></span></div>		</div>
		<div class="caption">
		<h1 class="title"><a href="https://www.smudailycampus.com/news/diverse-perspectives-create-groundbreaking-journalism-at-the-19th" rel="bookmark">Diverse Perspectives Create Groundbreaking Journalism at The 19th</a></h1>
		<p class="meta"><time datetime="2021-03-02T08:38:21-06:00">2021/03/02 at 8:38 AM</time><span class="bookmarks"><span class="hyphen">&nbsp;-&nbsp;</span>40 bookmarks</span></p>	</div>
</article><article class="post horiz-mini expt post-id-1058446 cover">
			<div class="thumbnail">
			<a href="https://www.smudailycampus.com/ae/maladjusted-the-podcast-exploring-racial-justice-on-campus" rel="bookmark"><img width="54" height="54" src="https://www.smudailycampus.com/wp-content/uploads/2021/03/Maladjusted-pod-cover-B-1-2-54x54.jpg" class="attachment-times-horiz-mini size-times-horiz-mini wp-post-image" alt="" srcset="https://www.smudailycampus.com/wp-content/uploads/2021/03/Maladjusted-pod-cover-B-1-2-54x54.jpg 54w, https://www.smudailycampus.com/wp-content/uploads/2021/03/Maladjusted-pod-cover-B-1-2-360x360.jpg 360w, https://www.smudailycampus.com/wp-content/uploads/2021/03/Maladjusted-pod-cover-B-1-2-72x72.jpg 72w, https://www.smudailycampus.com/wp-content/uploads/2021/03/Maladjusted-pod-cover-B-1-2-144x144.jpg 144w, https://www.smudailycampus.com/wp-content/uploads/2021/03/Maladjusted-pod-cover-B-1-2-108x108.jpg 108w, https://www.smudailycampus.com/wp-content/uploads/2021/03/Maladjusted-pod-cover-B-1-2-58x58.jpg 58w, https://www.smudailycampus.com/wp-content/uploads/2021/03/Maladjusted-pod-cover-B-1-2-116x116.jpg 116w, https://www.smudailycampus.com/wp-content/uploads/2021/03/Maladjusted-pod-cover-B-1-2.jpg 600w" sizes="100vw" /></a>
			<div class="tvote-wrap small"><span class="button"><a href="https://www.smudailycampus.com/wp-admin/admin-ajax.php?action=times_process_times_vote&nonce=8909635ff1&post_id=1058446&disabled=true&is_comment=false" class="tvote-button tvote-button-1058446" data-nonce="8909635ff1" data-post-id="1058446" data-iscomment="false"></a><img class="bookmark-small svg-inject" src="https://www.smudailycampus.com/wp-content/themes/times/img/bookmark-small.svg"></span><span class="context tooltip center-top"><span class="add">Bookmark?</span><span class="remove">Remove?</span></span></div>		</div>
		<div class="caption">
		<h1 class="title"><a href="https://www.smudailycampus.com/ae/maladjusted-the-podcast-exploring-racial-justice-on-campus" rel="bookmark">Maladjusted: The Podcast Exploring Racial Justice On Campus</a></h1>
		<p class="meta"><time datetime="2021-03-01T11:31:27-06:00">2021/03/01 at 11:31 AM</time><span class="bookmarks"><span class="hyphen">&nbsp;-&nbsp;</span>38 bookmarks</span></p>	</div>
</article><article class="post horiz-mini expt post-id-1058424 cover">
			<div class="thumbnail">
			<a href="https://www.smudailycampus.com/news/smu-plans-for-make-up-days-after-cancelling-classes" rel="bookmark"><img width="54" height="54" src="https://www.smudailycampus.com/wp-content/uploads/2021/02/Screen-Shot-2021-02-23-at-7.40.03-PM-54x54.jpg" class="attachment-times-horiz-mini size-times-horiz-mini wp-post-image" alt="" srcset="https://www.smudailycampus.com/wp-content/uploads/2021/02/Screen-Shot-2021-02-23-at-7.40.03-PM-54x54.jpg 54w, https://www.smudailycampus.com/wp-content/uploads/2021/02/Screen-Shot-2021-02-23-at-7.40.03-PM-72x72.jpg 72w, https://www.smudailycampus.com/wp-content/uploads/2021/02/Screen-Shot-2021-02-23-at-7.40.03-PM-144x144.jpg 144w, https://www.smudailycampus.com/wp-content/uploads/2021/02/Screen-Shot-2021-02-23-at-7.40.03-PM-108x108.jpg 108w, https://www.smudailycampus.com/wp-content/uploads/2021/02/Screen-Shot-2021-02-23-at-7.40.03-PM-58x58.jpg 58w, https://www.smudailycampus.com/wp-content/uploads/2021/02/Screen-Shot-2021-02-23-at-7.40.03-PM-116x116.jpg 116w" sizes="100vw" /></a>
			<div class="tvote-wrap small"><span class="button"><a href="https://www.smudailycampus.com/wp-admin/admin-ajax.php?action=times_process_times_vote&nonce=8909635ff1&post_id=1058424&disabled=true&is_comment=false" class="tvote-button tvote-button-1058424" data-nonce="8909635ff1" data-post-id="1058424" data-iscomment="false"></a><img class="bookmark-small svg-inject" src="https://www.smudailycampus.com/wp-content/themes/times/img/bookmark-small.svg"></span><span class="context tooltip center-top"><span class="add">Bookmark?</span><span class="remove">Remove?</span></span></div>		</div>
		<div class="caption">
		<h1 class="title"><a href="https://www.smudailycampus.com/news/smu-plans-for-make-up-days-after-cancelling-classes" rel="bookmark">SMU Plans for Make-Up Days After Cancelling Classes</a></h1>
		<p class="meta"><time datetime="2021-02-23T13:52:46-06:00">2021/02/23 at 1:52 PM</time><span class="bookmarks"><span class="hyphen">&nbsp;-&nbsp;</span>52 bookmarks</span></p>	</div>
</article><article class="post horiz-mini expt post-id-1058392 cover">
			<div class="thumbnail">
			<a href="https://www.smudailycampus.com/news/students-enjoy-snow-week-at-smu" rel="bookmark"><img width="54" height="54" src="https://www.smudailycampus.com/wp-content/uploads/2021/02/IMG_6592-54x54.jpg" class="attachment-times-horiz-mini size-times-horiz-mini wp-post-image" alt="" srcset="https://www.smudailycampus.com/wp-content/uploads/2021/02/IMG_6592-54x54.jpg 54w, https://www.smudailycampus.com/wp-content/uploads/2021/02/IMG_6592-72x72.jpg 72w, https://www.smudailycampus.com/wp-content/uploads/2021/02/IMG_6592-144x144.jpg 144w, https://www.smudailycampus.com/wp-content/uploads/2021/02/IMG_6592-108x108.jpg 108w, https://www.smudailycampus.com/wp-content/uploads/2021/02/IMG_6592-58x58.jpg 58w, https://www.smudailycampus.com/wp-content/uploads/2021/02/IMG_6592-116x116.jpg 116w" sizes="100vw" /></a>
			<div class="tvote-wrap small"><span class="button"><a href="https://www.smudailycampus.com/wp-admin/admin-ajax.php?action=times_process_times_vote&nonce=8909635ff1&post_id=1058392&disabled=true&is_comment=false" class="tvote-button tvote-button-1058392" data-nonce="8909635ff1" data-post-id="1058392" data-iscomment="false"></a><img class="bookmark-small svg-inject" src="https://www.smudailycampus.com/wp-content/themes/times/img/bookmark-small.svg"></span><span class="context tooltip center-top"><span class="add">Bookmark?</span><span class="remove">Remove?</span></span></div>		</div>
		<div class="caption">
		<h1 class="title"><a href="https://www.smudailycampus.com/news/students-enjoy-snow-week-at-smu" rel="bookmark">Students Enjoy Snow Week at SMU</a></h1>
		<p class="meta"><time datetime="2021-02-17T12:09:18-06:00">2021/02/17 at 12:09 PM</time><span class="bookmarks"><span class="hyphen">&nbsp;-&nbsp;</span>57 bookmarks</span></p>	</div>
</article>			</section>
	
			
			
		</aside>

	</div>
	</div>

<footer class="site-footer basic-layout customizer-logo custom-layout column-count-3">
	<div class="row">

	
	<div class="widget-area col"><section id="times_social_widget-3" class="widget bass widget_times_social_widget"><h2 class="widget-title"></h2><div class="facebook"><span class="text">Facebook</span><a href="https://facebook.com/thedailycampus" target="_blank"></a></div><div class="twitter"><span class="text">Twitter</span><a href="https://twitter.com/thedailycampus" target="_blank"></a></div><div class="instagram"><span class="text">Instagram</span><a href="https://www.instagram.com/smudailycampus/" target="_blank"></a></div><span class="social-count-plus"></span></section></div><div class="widget-area col"><section id="text-16" class="widget bass widget_text">			<div class="textwidget"><p dir="ltr"><strong>Mailing Address</strong></p>
<p>Division of Journalism<br />
Southern Methodist University<br />
PO Box 750113<br />
Dallas, TX 75275-0113</p>
</div>
		</section></div><div class="widget-area col"><section id="nav_menu-4" class="widget bass widget_nav_menu"><div class="menu-footer-2-container"><ul id="menu-footer-2" class="menu"><li id="menu-item-1056438" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-1056438"><a href="https://www.smudailycampus.com/staff/contact-our-staff">Contact Our Editors</a></li>
<li id="menu-item-1052803" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1052803"><a href="https://www.smudailycampus.com/advertising/advertising-policies-and-guidelines">Advertising Policies and Guidelines</a></li>
<li id="menu-item-1043859" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1043859"><a href="https://www.smudailycampus.com/online-policies">Online Policies</a></li>
<li id="menu-item-1048321" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1048321"><a href="https://www.smudailycampus.com/category/sponsoredcontent">College 101</a></li>
</ul></div></section></div>
	</div>
	<div class="row">
		<div class="site-branding">
			<div class="col st5"><span class="aligner"></span><a href="https://www.smudailycampus.com/" rel="home"><img width="202" height="48" src="https://www.smudailycampus.com/wp-content/uploads/2019/09/DC_Nameplat_200.58x48.png" alt="SMU Daily Campus - SMU&#039;s Student Newspaper"></a></div>
			<div class="col st10"><p class="footer-text-selective">© 2021. <a class="sitettl" href="https://www.smudailycampus.com">SMU Daily Campus</a>. All rights reserved.</p></div>
		</div>
	</div>
</footer><script data-cfasync='false'>window.broadstreetKeywords = ['not_home_page','not_landing_page','is_article_page','campuslife','news','featured','news','student-life','news','snowstorm-make-up-day-plan-does-not-receive-majority-student-approval','post']</script>
<script data-cfasync='false'>window.broadstreetTargets = {"pagetype":["post","not_home_page"],"category":["campuslife","news","featured","news","student-life","news","snowstorm-make-up-day-plan-does-not-receive-majority-student-approval","post"],"url":"snowstorm-make-up-day-plan-does-not-receive-majority-student-approval"};</script>
<script data-cfasync='false'>
window.broadstreet = window.broadstreet || { run: [] };window.broadstreet.run.push(function () {
window.broadstreet.watch({});
 });</script><!-- Instagram Feed JS -->
<script type="text/javascript">
var sbiajaxurl = "https://www.smudailycampus.com/wp-admin/admin-ajax.php";
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/www.smudailycampus.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>





<script src="https://www.smudailycampus.com/wp-content/cache/minify/3a685.js"></script>

<script type='text/javascript'>
(function ($) { "use strict"; $('#masthead .site-branding').imagesLoaded( function() { if ( $('#masthead .adele-wrap').length || $('#masthead .site-branding img').length ) {if (typeof scrollToContent !== 'undefined') scrollToContent();} }); })(jQuery);
</script>
<script type='text/javascript'>
var ajaxUrl="https://www.smudailycampus.com/wp-admin/admin-ajax.php";var rootUrl="https://www.smudailycampus.com/wp-content/themes/times";var siteLang="en";
</script>







<script src="https://www.smudailycampus.com/wp-content/cache/minify/24239.js"></script>

<script type='text/javascript'>
/* <![CDATA[ */
var timesVotes = {"ajaxurl":"https:\/\/www.smudailycampus.com\/wp-admin\/admin-ajax.php","like":"Like","unlike":"Unlike"};
/* ]]> */
</script>
<script src="https://www.smudailycampus.com/wp-content/cache/minify/62b6c.js"></script>

<script type='text/javascript'>
/* <![CDATA[ */
var viewsCacheL10n = {"admin_ajax_url":"https:\/\/www.smudailycampus.com\/wp-admin\/admin-ajax.php","post_id":"1058500","transient":"false"};
/* ]]> */
</script>

<script src="https://www.smudailycampus.com/wp-content/cache/minify/528fc.js"></script>


</body>
</html>

<!--
Performance optimized by W3 Total Cache. Learn more: https://www.boldgrid.com/w3-total-cache/

Page Caching using disk: enhanced 
Minified using disk
Database Caching 47/137 queries in 0.232 seconds using disk

Served from: www.smudailycampus.com @ 2021-03-08 17:54:05 by W3 Total Cache
-->